课堂小实验- 利用三层交换机实现VLAN间路由

原创 麻木  2019-03-08 10:57:40  阅读 615 次 评论 0 条
麻木博客

点击播放按钮播放音乐《夏天的风》

摘要:

实训目的:

掌握交换机Tag VLAN的配置

掌握三层交换机基本配置方法;

掌握三层交换机VLAN路由的配置方法;

通过三层交换机实现VLAN间相互通信;


实训背景:

某企业有两个主要部门,技术部和销售部,分处于不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN的划分,技术部和销售部处于不同的VLAN,先由于业务的需求需要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台三层交换机进行了连接。


技术原理:

三层交换机具备网络层的功能,实现VLAN相互访问的原理是:利用三层交换机的路由功能,通过识别数据包的IP地址,查找路由表进行选路转发,三层交换机利用直连路由可以实现不同VLAN之间的相互访问。三层交换机给接口配置IP地址。采用SVI(交换虚拟接口)的方式实现VLAN间互连。SVI是指为交换机中的VLAN创建虚拟接口,并且配置IP地址。


拓扑结构

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第1张



配置三台主机地址

PC1:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第2张


PC2:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第3张


PC3:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第4张


二层交换机配置

在二层交换机上配置VLAN2、VLAN3,分别将端口2、端口3划分给VLAN2、VLAN3。

Switch>en

Switch#conf

Configuring from terminal, memory, or network [terminal]? 

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#vlan 2 

Switch(config-vlan)#name jishu

Switch(config-vlan)#vlan 3

Switch(config-vlan)#name xiaoshou

Switch(config)#int f0/2

Switch(config-if)#switchport access vlan 2

Switch(config-if)#int f0/3 

Switch(config-if)#switchport access vlan 3

将二层交换机与三层交换机相连的端口f 0/1都定义为tag VLAN模式。

Switch(config)#int f0/1

Switch(config-if)#switchport mode trunk 

Switch(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up



三层交换机配置


将二层交换机与三层交换机相连的端口f0/1都定义为tag VLAN模式。

Switch(config)#int f0/1

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk 

设置三层交换机VLAN间的通信,创建VLAN2,VLAN3的虚接口,并配置虚接口VLAN2VLAN3IP地址。

Switch(config)#int vlan 2

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan2, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

Switch(config-if)#ip address 192.168.1.1 255.255.255.0

Switch(config-if)#no sh

Switch(config-if)#int vlan 3

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan3, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to up

Switch(config-if)#ip address 192.168.2.1 255.255.255.0

Switch(config-if)#no sh

在三层交换机上将端口f0/2划分给vlan2

Switch(config)#int f0/2

Switch(config-if)#switchport access vlan 2


如以上代码打完ping不通请开启路由功能再次尝试

开启路由交换功能

Switch(config)#IP routing


通过ping测试pc1与pc2的连通性

pc1 ping pc2结果:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第5张


pc2 ping pc1 结果:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第6张


pc2 ping pc3 结果:

课堂小实验- 利用三层交换机实现VLAN间路由 课堂小实验 三层交换机VLAN间路由 第7张

附上源文件 :

此处内容需要评论后才能查看。
点击去评论


教程到此结束 ,如对本篇文章有异议请点击右侧链接联系我修改:点我前往站长QQ


麻木博客公众号期待你的加入!!!

编辑:麻木

打赏 支付宝打赏 微信打赏
本文地址:https://www.mamublog.cn/post/31.html
版权声明:本文为原创文章,版权归 麻木 所有,欢迎分享本文,转载请保留出处!

推荐文章

麻木博客
麻木博客

发表评论


表情

还没有留言,还不快点抢沙发?